過去問ドリル

LinuCレベル1 システム管理 問28

システム管理/アカウント管理

rootで「groupdel devops」を実行したところ、エラーになりグループを削除できなかった。原因として考えられるものとして適切なものはどれか。

当サイトのオリジナル問題(LinuCレベル1の出題範囲「システム管理」に対応。実際の試験問題ではありません)

正解:D

解説

groupdel は、既存ユーザーのプライマリグループ(/etc/passwd の4番目のフィールドのGID)になっているグループを、通常は削除できません(-f を付けると強制的に削除できますが、プライマリグループを失うユーザーが残るため推奨されません)。その場合は、先に usermod -g で該当ユーザーのプライマリグループを別のグループに変えるか、ユーザー自体を削除してからgroupdelを実行します。補助グループとして所属しているユーザーがいるだけなら、削除は妨げられません。なお、グループを削除しても、そのGIDが所有者になっているファイルは残るため、必要に応じて find / -nogroup などで確認します。

選択肢ごとの解説

  • A誤り。補助グループの所属は /etc/group の該当行に記録されており、グループ削除とともに消えるだけで、削除は妨げられません。
  • B誤り。GIDの値の範囲は、groupdelで削除できるかどうかに関係しません。
  • C誤り。グループパスワードは通常設定しないもので、未設定でもgroupdelは実行できます。
  • D正しい。既存ユーザーのプライマリグループになっているグループは、groupdelで(-f を付けない限り)削除できません。
LinuCレベル1の問題を演習モードで解く